Network issue impacting file delivery

Incident Report for DTN

Resolved

Our operations team confirmed successful connections and we are considering the issue resolved.
Posted Jul 15, 2026 - 05:46 UTC

Monitoring

The primary server has been reestablished and customers should be able to connect to wxftp again.
Posted Jul 15, 2026 - 05:39 UTC

Identified

We have identified an issue connecting to one of our primary servers. We are working to move to a secondary server at this time.
Posted Jul 15, 2026 - 05:18 UTC

Investigating

We are currently experiencing a network issue that is impacting the delivery of all files sent via Wxftp. It is being investigated at this time.
Posted Jul 15, 2026 - 04:31 UTC
This incident affected: Weather Data/APIs (wxftp.dtn.com).