GOES East Outage

Incident Report for DTN

Resolved

We have seen GOES-E Satellite Images return. NOAA issues resolved.
Posted Jul 16, 2026 - 18:13 UTC

Identified

There is an upstream outage of GOES East data. We are awaiting updates and resolution from the provider.
Posted Jul 16, 2026 - 15:01 UTC
This incident affected: Weather Satellite Data (GOES-E Satellite, Global Satellite).